One Touch Dial Service - Some endpoints are not able to get their calendar.
Incident Report for Polycom Cloud Services
Resolved
Microsoft's fix has been fully propagated and OTD is now able to subscribe to calendar events normally via Microsoft Graph using delegated permission. This incident is now resolved.
Posted Apr 18, 2022 - 10:09 MDT
Monitoring
A fix has been implemented by Microsoft and is being deployed. We are monitoring the results.
Posted Apr 15, 2022 - 15:56 MDT
Identified
After investigation, Microsoft Engineers have been able to isolate the issue to certain access level to specific O365 mailbox folders when using delegated permission via Microsoft Graph API. Microsoft is currently working on a fix with high priority.
Posted Apr 15, 2022 - 10:28 MDT
Update
We are continuing to investigate this issue with Microsoft. This issue is only impacting a small subset of OTD tenants that are integrated with Microsoft O365 Graph as a service.
Posted Apr 14, 2022 - 18:00 MDT
Update
The issue appears to be isolated to a few OTD tenants that are integrated with Microsoft O365 Graph as a service (using service account) and it only impacts RP Trios that are calendar registered to OTD using OTD generated credentials.

While we continue to investigate, customers being impacted by this issue can switch OTD integration from service to application as a workaround, as explained at https://otd.plcm.vc/support/docs/calendars/office365-choose-how-to-connect.
Posted Apr 13, 2022 - 17:39 MDT
Update
We have a better understanding of the issue now and we are continuing to investigate. The issue appears to be isolated to a very small subset of customers using endpoint type "RP Trio" only. We will provide more updates as we progress with the investigation.
Posted Apr 13, 2022 - 14:13 MDT
Investigating
The issue seems to be impacting only a subset of endpoints. We are currently investigating.
Posted Apr 13, 2022 - 11:18 MDT
This incident affected: One Touch Dial Service.