Poly Lens - Web Portal is currently unavailable

Incident Report for Poly Cloud Services

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 11:37 MDT

Monitoring

The provider has successfully reverted their service changes in the affected regions. The web portal is now accessible, and we are actively monitoring the service for any further issues.
Posted Oct 29, 2025 - 15:10 MDT

Update

The issue appears to be related to a current Microsoft Azure CDN outage.
Posted Oct 29, 2025 - 10:45 MDT

Identified

Starting at approximately 16:00 UTC, our provider (Microsoft) began experiencing DNS issues resulting in availability degradation of some services. unfortunately this also appears to impacting our DNS records for Poly Lens. See https://azure.status.microsoft/en-us/status for additional information.
Posted Oct 29, 2025 - 10:44 MDT

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 10:20 MDT
This incident affected: Poly Lens.