OTD - Failure to retrieve endpoints

Incident Report for Poly Cloud Services

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 08:19 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 24, 2025 - 07:57 MDT

Investigating

We are investigating an OTD portal issue where some accounts are receiving the error "Failed to retrieve endpoints"
Posted Jun 24, 2025 - 06:30 MDT
This incident affects: One Touch Dial Service.