Re-send Invite function is not performing reliably

Incident Report for Poly Cloud Services

Resolved

This incident has been resolved.
Posted Oct 23, 2024 - 14:28 MDT

Identified

Email invites are working as expected. Re-send invite function in the Account Member tab is still not functioning properly - but root cause has been identified.
Posted Sep 24, 2024 - 15:21 MDT

Investigating

Email invites are occasionally failing...and the Re-send Invite function in the Account Member tab is not functioning properly.
Engineering is investigating the issue
Posted Sep 05, 2024 - 22:22 MDT
This incident affected: Poly Lens.