Poly Lens Portal: Device details, Edit function produces, "Cannot access device or it doesn't exist"

Incident Report for Poly Cloud Services

Monitoring

A fix has been implemented, and we are monitoring the results.

NOTE: This is a web-only change. Please force your browser to reload the Poly Lens website.
Posted Jun 18, 2025 - 14:47 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 17, 2025 - 11:00 MDT

Investigating

We are currently investigating this issue.
Posted Jun 17, 2025 - 11:00 MDT
This incident affects: Poly Lens.