Slow API response and page loads for device data

Incident Report for Poly Cloud Services

Postmortem

An update to VM image which included additional cyber monitoring increased our memory consumption at peak times; this combined with an update from our IoT provider that caused a higher connection load on a specific instance created a compound problem that created the slow API responses for device details. We scaled our instances and added additional memory consumption metrics to monitor performance going forward.

Posted Oct 29, 2025 - 09:58 MDT

Resolved

This issue has been resolved. The cause was twofold: 1) a security update on some of our hosts that led to increased memory consumption during peak hours, and 2) an update from our IoT provider that caused a higher connection load on a specific instance. We have since scaled our instances and added additional memory consumption metrics to monitor performance going forward.
Posted Oct 29, 2025 - 06:51 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2025 - 11:26 MDT

Investigating

We are currently investigating this issue.
Posted Oct 28, 2025 - 07:46 MDT
This incident affected: Poly Lens.