performance issues with search functions

Incident Report for Poly Cloud Services

Resolved

issue has been resolved
Posted May 29, 2026 - 16:16 MDT

Update

issue has been resolved
Posted May 29, 2026 - 14:31 MDT

Update

A fix is place and we are monitoring the results.
Posted May 29, 2026 - 12:05 MDT

Investigating

We are currently investigating this issue.
Posted May 29, 2026 - 11:48 MDT
This incident affected: Poly Lens.