Unable to authenticate to OTD portal and calendaring registration failures.

Incident Report for Poly Cloud Services

Resolved

This incident has been resolved.
Posted May 16, 2025 - 09:12 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 11:45 MDT

Investigating

We are currently investigating failures to access OTD portal and register calendar.
Posted May 15, 2025 - 07:18 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 17:54 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 17:47 MDT

Investigating

We are currently investigating an issue impacting access to the portal and calendaring.
Posted May 14, 2025 - 16:50 MDT
This incident affected: One Touch Dial Service.