Calendar integrations may have stale calendar information for some rooms.

Incident Report for Poly Cloud Services

Monitoring

Microsoft has updated the timeline for the identified the issue in the backend EXO and the expected ‘rollout’ of the fix to full ‘WW’ production endpoints will now be Tuesday, March 17th, 2026.
Posted Mar 10, 2026 - 13:17 MDT

Investigating

We are currently investigating this issue.
Posted Mar 02, 2026 - 15:14 MST
This incident affects: Poly Lens.