Poly LENS - site access & inventory display

Incident Report for Poly Cloud Services

Update

A fix is in place and we are monitoring.
Posted Sep 15, 2026 - 15:24 MDT

Investigating

We are currently investigating this issue.
Posted Sep 15, 2026 - 07:27 MDT
This incident affects: Poly Lens.