Poly Lens - Performance Issues
Incident Report for Poly Cloud Services
Resolved
Amazon AWS resolved performance issue.
Posted Sep 19, 2023 - 10:11 MDT
Identified
We are currently experiencing increased error rates and performance lag due to a confirmed network issue by AWS. They have identified the root cause and are working on a mitigation. We'll continue monitoring the issue and update the status as more information becomes available.
Posted Sep 18, 2023 - 14:18 MDT
This incident affected: Poly Lens.