Delayed responses in IoT messages

Incident Report for Poly Cloud Services

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 10:40 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2025 - 11:09 MDT

Identified

We've escalated the issue to our IoT provider (Microsoft). The issue appears to be related to a bug related to service update and an escalation has been raised with their engineering team. We will update the issue as we receive updates from our provider.
Posted Jun 03, 2025 - 09:43 MDT

Investigating

"We are currently investigating delays in IoT message delivery from the cloud to devices. These delays may affect new device onboarding and troubleshooting APIs, such as log collection and device reboot commands."
Posted Jun 03, 2025 - 08:32 MDT
This incident affected: Poly Lens.