Issues with joining RealConnect for Teams calls
Incident Report for Polycom Cloud Services
Resolved
This incident has been resolved. After reverting the SDK and API changes we've seen no additional signs of failure. We continue to work with Microsoft to understand the lobby bypass / anonymous join behavior in the new SDK so this won't reoccur with future updates.
Posted May 06, 2020 - 18:17 MDT
Monitoring
A fix has been implemented and we are monitoring the results. The bug fixed we released yesterday pulled in changes to improve call quality reporting and new SDK from Microsoft. We addressed the API conflict with the new SDK last night which addressed the apparent calls failures; however, customers with "Anonymous users can join meeting" set to no, still experienced issues joining calls after even the API was updated to match the SDK version. We've reverted both changes to the old SDK/API and will work with Microsoft to clarify the new SDK/API requirements with regards to lobby bypass/anonymous join behavior.
Posted May 06, 2020 - 09:07 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 06, 2020 - 08:20 MDT
Investigating
We are still seeing instances of failure with end reason "TeamsAgent failed joining call" The team is continuing to investigate the issue.
Posted May 06, 2020 - 07:49 MDT
Monitoring
A fix has been implemented and we are monitoring the results

A recent bug fix pushed to the production deployment reset an environment variable which resulted in an incorrect API being used with the new Teams SDK to connect calls. We updated the variable so the proper API is now being used to align with the SDK version.
Posted May 05, 2020 - 21:04 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 05, 2020 - 20:33 MDT
Investigating
We received numerous reports of issues with joining RealConnect for Teams calls. The team is currently investigating the issue.
Posted May 05, 2020 - 19:45 MDT
This incident affected: Poly RealConnect (NALA, EMEA, APAC, Calling).