errors when logging into lens.poly.com portal

Incident Report for Poly Cloud Services

Resolved

issue has been resolved
Posted Jul 23, 2026 - 07:02 MDT

Monitoring

a fix is in place, continuing to monitor.
Posted Jul 22, 2026 - 16:40 MDT

Investigating

We are currently investigating the issue.
Posted Jul 22, 2026 - 16:17 MDT
This incident affected: Poly Lens.