OTD-Delayed Calendar Events
Incident Report for Poly Cloud Services
Resolved
This incident has been resolved.
Posted Mar 22, 2019 - 17:35 MDT
Investigating
The Poly team is investigating delayed pushes of calendar events to Cisco devices.
Posted Mar 22, 2019 - 11:22 MDT
This incident affected: One Touch Dial Service.